Forum          FAQ

Loading

Board index » Dell Discussion and Support Forums » XPS 630i - Fan / Light / Master I/O / HDD Light / LightFX 2.0 Problems




 [ 3 posts ] 
Author Message
 Post subject: Problem with Northbridge Fan on my XPS 630i
 Post Posted: Thu Dec 05, 2013 6:54 am 
Offline
Member
Member

Joined: Tue Sep 24, 2013 2:10 am
Posts: 4
Hello,

I have a problem with northbridge fan on my XPS 630i. It creates a screeching sound similar to an electric saw, weird thing is that sometimes it's louder and sometimes it stops completely. i don't know what's causing it, also tried cleaning with compressed air and checked for anything that could be stuck but found nothing. The sound seems to be coming from northbridge fan but could also be coming from CPU fan. Is there a way of verifying this? I would really appreciate any help with this problem.

Thanks!


Top 
  
 
 Post subject: Re: Problem with Northbridge Fan on my XPS 630i
 Post Posted: Thu Dec 05, 2013 2:24 pm 
Offline
Board Moderator
Board Moderator
User avatar

Joined: Fri May 30, 2008 7:40 pm
Posts: 2864
Location: Elkhart, Indiana (USA)
The best way to determine the source of the noise is to open the case and check (being careful to not touch any components in the process while it's running). IIRC, the northbridge fan can be replaced (someone posted about this a while ago), as well as the stock cooler.

_________________
Dell XPS 8700 | Core i7 4770 3.4GHz | BIOS A11 | Windows 7 Pro 64-bit SP1 | 16GB G.SKILL DDR3 Sniper 1600MHz | EVGA GeForce GTX 970 SC | Dell S2340M 23" IPS LED | Seasonic 650W M12II-650 | Samsung SSD 850 EVO 1TB | Toshiba DT01ACA100 1TB | ASUS Xonar DX 7.1 | ASUS DRW-24B1ST | Logitech G100S | Dell SK-8135 keyboard | Logitech Cordless Rumblepad 2


Top 
  
 
 Post subject: Re: Problem with Northbridge Fan on my XPS 630i
 Post Posted: Sun Dec 08, 2013 4:07 am 
Offline
Member
Member

Joined: Tue Sep 24, 2013 2:10 am
Posts: 4
Thanks for your reply,

that's what i tried initially but wasn't sure since the Northbridge is so close to CPU.

I just got error message: NB Fan Failure message upon boot! so that confirms it!

I'll check out the other post for replacement info and will post back if any issues should come up.

Thanks again for your support!


Top 
  
 
 
 [ 3 posts ] 

Board index » Dell Discussion and Support Forums » XPS 630i - Fan / Light / Master I/O / HDD Light / LightFX 2.0 Problems


Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to: